Latest News

Configure OSPF without AREA 0: CCNP OSPF Case Study

Case Study: - Running OSPF without AREA 0

Author: - Amarjit Singh

Document Type: - Informational

Introduction

Topology used is as shown below

clip_image002

3 Routers are connected with ABR on 3 different AREA’s as shown in above topology diagram.

ABR Router connectivity summary:

Interface

IP Address

OSPF AREA

Remote Connected Router

Interface F0/0

1.1.1.1/30

Area 1

AREA-1

Interface S1/0

2.2.2.1/30

Area 2

AREA-2

Interface E2/0

3.3.3.1/30

Area 3

AREA-3

Interface E2/1

4.4.4.1/24

Reserved for Area 0

AREA-4

Now without configuring AREA 0, no OSPF routes are showing in the routing table. Only direct connected routed are available in the routing table as shown below.

clip_image004

FIGURE 1

clip_image006

FIGURE 2

Also from routers at Area 1, Area 2 & Area 3 only directly connected IP’s are pinging.

clip_image008

FIGURE 3

Now let’s have a look after configuring AREA 0 at ABR. Here I am configuring the IP address 4.4.4.1/24 on the Interface E2/1 in OSPF Area 0 (Refer to ABR Router connectivity summary table)

clip_image010

FIGURE 4

And output of “show ip ospf databse” on ABR before (FIGURE 5) and after (FIGURE 6) configuring AREA 0

clip_image012

FIGURE 5

clip_image014

FIGURE 6

SUMMARY

OSPF will not run without AREA 0. We must have to configure "AREA 0" to run the OSPF. No OSPF routes will be shown in "show ip route". Reason behind this is, each area has its own link state databases which will be shared with AREA 0 only by default. And AREA 0 will then flood the IA routes to other AREA's.

Exception: If using only one area say area 11 and no other area is there then no need to create AREA0

It means to flood LSA 1 and LSA 2, no need to create area 0, but for all other LSA's to be flooded properly, say LSA 3, LSA 4, LSA 5 & LSA 7 AREA 0 is must.

I want to bring one more thing in your notice... and its amazing.... Without creating AREA 0 on ABR, the output of the command "show ip ospf neig" is

ABR#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
10.10.10.2 1 FULL/DR 00:00:39 1.1.1.2 FastEthernet0/
0
10.10.10.3 0 FULL/ - 00:00:37 2.2.2.2 Serial1/0
10.10.10.4 1 FULL/DR 00:00:37 3.3.3.2 Ethernet2/0

Here the interesting thing is "FULL" state. It means if the neighbor ship is in "FULL" state and if OSPF routes are not showing in the routing tabe, then you are not connected with AREA 0. SIMPLE...

The router which is calling as ABR actually is not an ABR. Because ABR is that router whose one leg is connected in area 0. So it clears in my scenario that no area 0 is used then no ABR is present. If no ABR is present then no LSA will be flooded (except LSA1 & LSA2).


In my scenario, the router in multiple areas would know all the destinations (subnets in various areas), but would not propagate them between the areas (as it's not an ABR). Therefore, a router residing solely in area 1 would not receive subnets from area 2 and would not be able to communicate with another router that resides solely in area 2.

Configuration of ABR:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ABR

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

!

!

!

!

!

!

!

interface Loopback0

ip address 10.10.10.1 255.255.255.255

!

interface FastEthernet0/0

ip address 1.1.1.1 255.255.255.252

duplex auto

speed auto

!

interface Serial1/0

ip address 2.2.2.1 255.255.255.252

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

interface Ethernet2/0

ip address 3.3.3.1 255.255.255.252

half-duplex

!

interface Ethernet2/1

ip address 4.4.4.1 255.255.255.0

half-duplex

!

interface Ethernet2/2

no ip address

shutdown

half-duplex

!

interface Ethernet2/3

no ip address

shutdown

half-duplex

!

router ospf 1

log-adjacency-changes

network 1.1.1.0 0.0.0.3 area 1

network 2.2.2.0 0.0.0.3 area 2

network 3.3.3.0 0.0.0.3 area 3

network 4.4.4.0 0.0.0.255 area 0

!

ip http server

!

!

!

!

control-plane

!

banner motd


***********************

* *

*THIS IS ABR ROUTER*

***********************


!

line con 0

password cisco123

login

line aux 0

line vty 0 4

password cisco123

login

!

!

end

No comments:

Post a Comment

Contact Us

24x7 online , we happy to answer you
tamilcypc@gmail.com , ,manoj960000@gmial.com.
skype: greeenchip

Disclaimer

This Blog and its TUT's are intended for educational purposes only, no-one involved in the creation of this TuT may be held responsible for any illegal acts brought about by this Blog or TuT.



Featured Post

Custom Domains And HTTPS Redirection Code